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TATWEER PETROLEUM – BAHRAIN FIELD DEVELOPMENT COMPANY W.L.L
(“TATWEER”)

Suppier User - Quick Reference to Access Key ISUPPLIER PORTAL Functionality
IMPORTANT:

Processes, applications and business rules included in this Quick Reference are being implemented worldwide beginning with Tatweer’s operations in the
United States, Sultanate of Oman, State of Qatar, Republic of Yemen, United Arab Emirates, Republic of Bolivia, Republic of Colombia and Great Socialist
People's Libyan Arab Jamahiriya . Additional countries/subsidiaries will be included in the coming months.

Please note that iSupplier Portal registration, access and/or usage does not imply a contract, or intent to purchase goods or services from registered suppliers
by Tatweer.

This Quick reference describes how to access the key iSupplier Portal functionality. However, Supplier user must use the iSupplier Portal User Handbook and
the Frequently Asked Questions at http://Suppliersupport.tatweerpetroleum.com to know how to use the iSupplier Portal and its business implications.

Action TAB/Screen Quick Reference
Reset Password Login Screen  Click on the Login Assistance hyperlink.

 In the User Name field, enter your username and click on the Forgot Password button to
reset your password. An email with instructions is automatically sent to the email associated
with the username (it can take up to an hour).

 Alternatively, you can contact the iSupplier Portal Security Administrator within your company
to reset the password.

Get Username Login Screen  Click on the Login Assistance hyperlink.
 In the Email field, enter your email (the email used in registration) and click on the Forgot

User Name button. An email with your username is automatically sent to your registered
email.

Notifications Home  In the Notifications section, find the list of your pending notifications.
 To display all your notifications, click on the Full List button.
 To respond to a notification, click on the Notification Subject hyperlink.
 Notifications do not provide all the data or functionality to fully satisfy the requirement. To

execute the action, go to the specific screen.
Supplier
Registration
information

Admin  IMPORTANT: This information can only be entered or updated by the supplier during the
registration and qualification process. Once the qualification process is completed, this data
can only be viewed. If the supplier identifies data to be added, modified or removed, please
use the Supplier Registration Information Modification Form available at
http://Suppliersupport.tatweerpetroleum.com to submit any changes.

View Organization
Details

Admin  Click on the Organization hyperlink in the Profile Management navigation tree.

View Addresses Admin  Click on the Address Book hyperlink in the Profile Management navigation tree.
 Click on the pencil icon in the Update column.
 View the data and go back to the previous web page by clicking on the Admin Profile

Management Address Book hyperlink on the web page top left.
 IMPORTANT: Check the address purpose by viewing the checked boxes.

o RFQ Only Address: Address (and email address) used only to receive sourcing documents
such as Request for Information, Request for Quotation and/or Auctions.

o Purchasing Address: Address (and email address) to receive sourcing document such as
Request for Information, Request for Quotation and/or Auctions and purchasing document
such as Purchase Order, Service Orders or Contracts.

o Payment Address: Address (and email address) to receive payments. Electronic payments
require the physical address of your company (and email address).

View Contacts Admin  Click on the Contact Directory hyperlink in the Profile Management navigation tree.
 Note: It can be only updated by the Supplier Security Administrator in your company.

View Products and
Services

Admin  Click on the Products and Services hyperlink in the Profile Management navigation tree. The
Products and Services web page lists the products and services your company can provide
based on the Tatweer-selected UNSPSC (United Nations Standard Products and Services
Code) codes and descriptions at the class level. For more information, visit www.unspsc.org.

View Banking
Details

Admin  Click on the Banking Details hyperlink in the Profile Management navigation tree.
 In the View dropdown, select All Accounts and click on the Go button.
 Main data for all bank accounts will be shown.
 To view details about a specific bank account, click on the account and click on the pencil

icon in the Update column.
View Payments
and Invoicing
Preferences

Admin  Click on the Payment and Invoicing hyperlink in the Profile Management navigation tree.

Review a Request
Information (RFI),
Request for
Quotation (RFQ) or

Negotiations  In your company’s Open Invitations section, view the most recent open invitations.
 Review a specific document before acknowledging and responding by clicking on the

Negotiation Number hyperlink. The document summary web page will be shown.
 Click on the Header tab, review information.

http://suppliersupport.tatweerpetroleum.com/
http://suppliersupport.tatweerpetroleum.com/
http://www.unspsc.org/
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Auction  IMPORTANT: verify the event field. It will explain if you are participating in a Qualification,

Sourcing or Performance Monitoring event. See the iSupplier Portal User Handbook
 Click on the Lines tab to only review products and services and quantities requested in the

RFQ or Auction.
 Click on the Controls tab to review date and response rules. Important: Take note of the

close date.
 Click on the Contract Terms tab. In the Deliverable section, access a specific deliverable by

clicking on the Deliverable Name hyperlink. Click on the Preview Contract Terms button to
view, save and print the Terms and Conditions.

 As needed, in the Actions dropdown, select the option Printable View and click on the Go
button to view, save and print the document (all tab information and the terms and conditions
can be viewed in the same document).

 As needed, use the Online Discussion functionality to request or provide additional
information regarding the document. This replaces any email communication.

Acknowledge a
Request
Information (RFI),
Request for
Quotation (RFQ) or
Auction

Negotiations  After reviewing, printing the document (RFI/RFQ/Auction) and clarifying any issues,
acknowledge the document to indicate if your company will participate in the event.

 In the Actions dropdown, select the option Acknowledge Participation and click on the Go
button to access the specific web page.

 In the Will your Company participate? section, check the appropriate button.
 If needed, in the Note to Buyer textbox, type a message for the buyer (Tatweer employee

responsible for the event).
 Click on the Apply button.

Respond to a
Request
Information (RFI),
Request for
Quotation (RFQ) or
Auction

Negotiations Response for RFI/RFQ/Auction
 After reviewing, printing the document (RFI/RFQ/Auction) and clarifying any issues, in the

Actions dropdown, select the option Create Response/Quote/Bid and click on the Go button
to access the specific web page.

IMPORTANT: Click on “Save Draft” button before conducting any additional action.

 In the Requirements section, click on the Expand All hyperlink to respond to each
requirement and enter the appropriate response values.

 As needed, attach any appropriate support documentation to the response in the Attachment
section by clicking Add Attachment button

 As needed, respond to deliverables requesting specific documentation. Scroll down to the
Deliverables section.
o Respond to the deliverable by selecting the pencil icon in the Update column.
o In the Notes field, write an explanation about the information that is being submitted.
o Click on the Add Attachment button to attach any required documents.
o In the Status dropdown, choose Submitted
o Click on the Apply button.

 As needed, quote/bid by clicking on the Lines tab
o In the Line Price column, enter price for the quote price.
o Click on the Update icon in each line to add cost factors or a specific attachment or to

respond to attributes/cost factors and attach information as applicable.
o Click on the Apply button and repeat as needed.

Submit the RFI/RFQ/Auction Response
 After completing all the RFI/RFQ/Auction sections, submit your response.
 In the Response Valid Until field, enter a date later than the close date.
 To review the response before submitting it, click on the View RFI button.
 To save a draft and later continue working on the response, click on the Save Draft button.

See Manage Draft section.
 Click on the Continue button.
 Click on the Validate button to verify the response before submitting it.
 Click on the Submit button. A confirmation message is shown.

Print a Request
Information (RFI),
Request for
Quotation (RFQ) or
Auction

Negotiations  Print your company’s response by using the internet explorer print functionality.
 Find and access the RFI/RFQ/Auction response as explained in the Review a

RFI/RFQ/Auction section.
 In the Internet Explorer menu, click on the File menu and then the Print… option.
 Print the document.

View Purchasing
Document
(Contracts,
Purchase Orders,
Service Orders)

Orders  View all key summary information about the purchasing document.
 Click on the hyperlinks to access specific details.
 Click on the specific PO Number hyperlink to access the purchasing document details

including both header and line information, such as Terms and Conditions, Lines, Shipments,
and Attachments.

Acknowledge and
Accept Purchasing
Documents
(Contracts,
Purchase Orders,
Service Orders)

Orders  After receiving a notification that requires purchasing document acknowledgement and
acceptance, login to the iSupplier Portal.

 Click on the Order tab, find the specific purchasing document. The Status column will
indicate Requires Acknowledgment.

 Review the purchasing document by clicking on the specific PO Number hyperlink to access
the purchasing document details.

 In the Actions dropdown, choose Acknowledge and click on the Go button.
 Click on the Accept Entire Order or Reject Entire Order button.
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 Click on the Submit button.
IMPORTANT: To allow Supplier to view and print the Purchasing Document with the terms and
conditions, the Buyer needs to attach the document in the Attachment Section. If the document is
not available, request the appropriate Buyer to attach the documentation.

View and Submit
Contractual
Deliverables

Orders  Click on the Deliverables sub-tab link.
 Populate the search criteria and click on the Go button to access deliverables.
 View all the related deliverable details by clicking on the specific Deliverable Name hyperlink.
 Respond to the deliverable by selecting the pencil icon in the Update column.
 In the Notes field, write an explanation about the information being submitted.
 Click on the Add Attachment button to attach any required documents.
 If needed, go to the Status History and click on the Show hyperlink to view additional details

about the changes.
 In the Status dropdown, choose Submitted.
 Click on the Apply button.

View Advance
Shipping Notice
(ASN)

Shipment  Click on the Shipment tab and use the View dropdown option to view the ASN.
 In the View dropdown, choose view the Last 25 Shipment Notices or All Shipment Notices

option and click on the Go button. If necessary, click on the Advance Search button to search
the specific ASN.

 View specific ASN details by clicking on the Shipment Number hyperlink.
Create Advance
Shipping Notice

Shipment  Click on the Shipment Notices sub-tab.
 Click on the Create Advance Shipment Notices hyperlink.
 Under the Views section, in the View dropdown, choose the Shipments Due option.
 Click on the Go button.
 All purchase order shipments are listed.
 In the Select column, select the purchasing document by checking the applicable purchasing

document related to the shipment. More than one purchasing document can be selected.
 Click the Add to Shipment Notice button.
 In the Shipments in Advance Shipment Notice section, populate applicable date for each line.
 Click on the Shipping Header sub-tab.
 In the Shipment Information section, populate applicable data.
 Click on the Preview button to view the ASN before submitting it.
 Click on the Submit button.

Cancel Advance
Shipping Notice

Shipment  Click on the Shipment tab and use the View dropdown option to view the ASN.
 If needed, click on the Advance Search button to search the specific ASN.
 In the Select column, select the ASN to cancel by checking the button.
 Click on the Cancel Shipment Notice button.

View Receipts Shipment  Click on the Receipts sub-tab hyperlink
 Populate search criteria
 Click on the Go button to access applicable receipts.
 Click on the Receipt Number hyperlink to view details.
 View main receipt-related information in the line.

View Returns Shipment  Click on the Returns sub-tab hyperlink
 Populate search criteria
 Click on the Go button to access applicable receipts.
 Click on the Receipt Number hyperlink to view details.
 View main return-related information

View Invoices Finance  Click on the View Invoices sub-tab hyperlink
 Populate search criteria
 Click on the Go button to access invoice information
 View and access the invoice information by clicking on the specific Invoice, PO Number,

Receipts or Attachment hyperlinks.
View Payment Finance  Click on the View Payments sub-tab hyperlink

 Populate search criteria
 Click on the Go button to access applicable payment information.
 View and access payment information by clicking on the specific Payment, PO Number, or

Invoice hyperlinks.


